Cálculos en filtros Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Cálculos en filtros Excel, sobre los datos filtrados, si realizamos un cálculo sobre los resultados, nos aplicará los valores de las celdas ocultas (no filtrados).

Disponemos de los datos de los trabajadores de nuestra empresa (rango A1:G14) y deseamos sumar la columna de sueldo (F1:F14) filtrada por el valor de 1.200, en nuestro caso se muestran tres resultados.
Si aplicamos la función SUMA "=SUMA(F2:F14)" sobre ellos, nos mostrará también en el resultado los valores ocultos, por ello recurrimos a la función SUBTOTALES.

Emplearemos las siguientes funciones, anidándolas:

  • Función SUBTOTALES. Devuelve un subtotal en una lista o base de datos SUMA. Suma sus argumentos.

  1. Ir a: Celda F16 / Escribir:

    =SUBTOTALES(9;F2:F14)

    Celda donde obtener la suma de los resultados del filtro.

    Cálculos en filtros Excel: Datos con filtro de sueldo 1200, Celda F16 con la suma de los resultados.
  2. Borrar el filtro y aplicar otro valor de sueldo, verificar como recalcula el total sumado basado en los datos filtrados.

  • En la función, indicamos el argumento con un número de 1 a 11 (incluye los valores ocultos) o de 101 a 111 (pasa por alto valores ocultos) que indica qué función debe usarse para calcular los subtotales dentro del rango.

FunciónOcultos incluidosOcultos no incluidos
PROMEDIO1101
CONTAR2102
CONTARA3103
MAX4104
MIN5105
PRODUCTO6106
DESVEST7107
DESVESTP8108
SUMA9109
VAR10110
VARP11111

Cuando deseamos cálculos en filtros Excel (autofiltros) podemos aplicar la función SUBTOTALES.

Nivel de dificultad: Básico Excel Básico

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *