Calcular la edad a partir de fecha de nacimiento en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Mediante funciones podemos calcular la edad a partir de fecha de nacimiento en Excel.

Obtenemos los años a partir de una fecha en formato "dia/mes/año" o "año" a la fecha actual o entre dos fechas.

Calcular edad a partir de fecha de nacimiento en Excel

En la columna A disponemos de la fecha de nacimiento y en la columna B se mostrará la edad en años (considerando que la fecha actual para la función HOY es 11/06/2016).

 AB
1FechaEdad
201/01/1998 
320/10/1961 
417/05/1973 
501/05/2016 
605/07/1972 
706/03/2000 
821/05/1970 
916/11/1998 
102010 
  • FUNCIÓN: AÑO Y HOY

  1. Ir a: Celda B2 / Escribir:

    =(AÑO(HOY())-AÑO(A2))

    Para obtener los años entre dos fechas: =(AÑO(A3)-AÑO(A2))

    Celda B2 mostrando 18 como la edad del 01/01/1998 a la fecha 11/06/2016 (HOY).
  • FUNCIÓN: ENTERO, FRAC.AÑO Y HOY

  1. Ir a: Celda B3 / Escribir:

    =ENTERO(FRAC.AÑO(A2;HOY()))

    Para obtener los años entre dos fechas: =ENTERO(FRAC.AÑO(A2;A3))

    Celda B3 mostrando 54 como la edad del 20/10/1961 a la fecha 11/06/2016 (HOY).
  • FUNCIÓN: SIFECHA Y HOY

  1. Ir a: Celda B4 / Escribir:

    =SIFECHA(A2;HOY();"y")

    Para obtener los años entre dos fechas: =SIFECHA(A2;A3;"y")

    Celda B4 mostrando 43 como la edad del 17/05/1973 a la fecha 11/06/2016 (HOY).
  • FUNCIÓN: TRUNCAR, FRAC.AÑO Y HOY

  1. Ir a: Celda B5 / Escribir:

    =TRUNCAR(FRAC.AÑO(A2;HOY();1))

    Para obtener los años entre dos fechas: =TRUNCAR(FRAC.AÑO(A2;A3;1))

    Celda B5 mostrando 0 como la edad del 01/05/2016 a la fecha 11/06/2016 (HOY).
  • FUNCIÓN: ENTERO Y HOY

  1. Ir a: Celda B6 / Escribir:

    =ENTERO((HOY()-A2)/365,25)

    Para obtener los años entre dos fechas: =ENTERO((HOY()-A2)/365,25)

    Celda B6 mostrando 43 como la edad del 05/07/1972 a la fecha 11/06/2016 (HOY).
  • FUNCIÓN: FRAC.AÑO Y HOY

  1. Ir a: Celda B7 / Escribir:

    =FRAC.AÑO(A2;HOY())

    Para obtener los años entre dos fechas: =FRAC.AÑO(A2;A3)

    Celda B7 mostrando 16,26 como la edad del 06/03/2000 a la fecha 11/06/2016 (HOY).
  • FUNCIÓN: HOY (365)

  1. Ir a: Celda B8 / Escribir:

    =(HOY()-A2)/365,25

    Para obtener los años entre dos fechas: =(A3-A2)/365,25

    Celda B8 mostrando 46,05 como la edad del 21/05/1970 a la fecha 11/06/2016 (HOY).
  • FUNCIÓN: TEXTO Y HOY

  1. Ir a: Celda B9 / Escribir:

    =TEXTO(HOY()-A2;"aa")&" años"

    Para obtener los años entre dos fechas: =TEXTO(A3-A2;"aa")&" años"

    Celda B9 mostrando 17 AÑOS como la edad del 16/11/1998 a la fecha 11/06/2016 (HOY).
  • FUNCIÓN: AÑO Y HOY

  1. Ir a: Celda B10 / Escribir:

    =AÑO(HOY())-A10

    Para obtener los años entre dos fechas: =AÑO(A3)-A10

    Celda B10 mostrando 6 como la edad del 2010 a la fecha 2016.

   

Nivel de dificultad: Avanzado Excel Avanzado

5 comentarios en “Calcular la edad a partir de fecha de nacimiento en Excel

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *