Calcular el total acumulado por día en excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

En ocasiones necesitamos conocer como calcular el total acumulado por día en Excel, es decir, que nos muestre el total acumulado por cada día.

En nuestro caso la columna A muestra la fecha de las ventas, la columna B muestra el nombre del cliente, la columna C la base imponible de la factura, la columna D el importe del IVA de la factura y la columna E el importe total de la factura.

 ABCDE
1FechaClienteBase ImponibleIVATotal
202/01/2015Empresa 11.250,00262,501.512,50
302/01/2015Empresa 22.150,00451,502.601,50
402/01/2015Empresa 31.379,00289,591.668,59
503/01/2015Empresa 41.897,00398,372.295,37
603/01/2015Empresa 53.200,00672,003.872,00
703/01/2015Empresa 61.595,00334,951.929,95
803/01/2015Empresa 72.259,00474,392.733,39
904/01/2015Empresa 81.970,00413,702.383,70
1004/01/2015Empresa 91.121,00235,411.356,41
1104/01/2015Empresa 102.300,00483,002.783,00
1205/01/2015Empresa 12.586,00543,063.129,06
1305/01/2015Empresa 33.276,00687,963.963,96
1405/01/2015Empresa 51.121,00235,411.356,41
1505/01/2015Empresa 64.655,00977,555.632,55
1605/01/2015Empresa 71.350,00283,501.633,50
1705/01/2015Empresa 138.966,008.182,8647.148,86
1805/01/2015Empresa 113.190,002.769,9015.959,90
  • ACUMULADO SOBRE EL DÍA

Deseamos que nos calcule el acumulado .

  1. Ir a la Celda C2 / Escribir: 1.250,00. Como el primer valor, D2 mostrará el importe de IVA y E2 el importe total para el acumulado.

  2. Ir a Celda F2 y Escribir:

    =SI(A2<>A1;$E2;SI(A2=A1;$F1+$E2;$E2+$E1))

    Sí A2 es diferente a A1 muestra el valor de E2 y Sí es igual muestra
    la suma de F1 y E2. Si no se cumple ninguna de las condiciones
    muestra la suma de E2+E1.

     

  3. Copiar la celda F2 / Pegar en el rango F3:F18. O en el rango deseado.

    Celda F2 mostrando la función anidada =SI(A2<>A1;$E2;SI(A2=A1;$F1+$E2;$E2+$E1))
  4. Verificar como F4 muestra el acumulado del día 2 (A2, A3 y A4) y así el resto de los días.

 

Sugerencia: Aplicar en la columna F un formato condicional que nos resalte el último valor de cada día.

  • ACUMULADO SOBRE EL DÍA MOSTRANDO EN BLANCO

Deseamos que nos calcule el acumulado .

  1. Ir a la Celda C2 / Escribir: 1.250,00. Como el primer valor, D2 mostrará el importe de IVA y E2 el importe total para el acumulado.

  2. Ir a Celda G2 y Escribir:

    =SI($A2=$A3;"";SI(A2<>A1;"";SI(A2=A1;$F1+$E2;$E2+$E1)))

    Sí A2 es igual a A3, muestra la celda vacía; Sí A2 es diferente a A1, muestra la celda vacía; Sí A2 es igual a A1, muestra la suma de F1+E2 y sí no se cumple ninguna condición muestra la suma de E2 y E1.

     

  3. Copiar la celda G2 / Pegar en el rango G3:G18. O en el rango deseado.

    Celda G2 mostrando la función anidada, Acumulado en G4, G8, G11 y G18
  4. Verificar como G4 muestra el acumulado del día 2 (A2, A3 y A4) sin mostrar el valor de G2 y G3. Y así el resto de los días.

 

– Consultar: Calcular el total acumulado.

 
 

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *