Calculadora de números primos en Excel.

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Para conocer si un número es primo o no, te mostramos la calculadora de números primos en Excel.

Un número es primo cuando es entero positivo, distinto de 0 y 1 y que únicamente se puede dividir por sí mismo y por 1 para dar una solución exacta.

El número 2 también cumple las características de número primo; y es el único número primo que es par.

Emplearemos las siguientes funciones anidándolas:

  • Función SI. Especifica un texto lógico para ejecutar.
  • Función SUMAPRODUCTO. Devuelve la suma de los productos de los componentes de la matriz correspondiente.
  • Función N. Devuelve un valor convertido en un número.
  • Función RESIDUO. Devuelve el resto de la división.
  • Función FILA. Devuelve el número de fila de una referencia.
  • Función INDIRECTO. Devuelve una referencia indicada por un valor de texto.
  • Función ENTERO. Redondea un número hasta el entero inferior más próximo.
  • Función RAIZ. Devuelve la raíz cuadrada de un número.
  • Función VERDADERO. Devuelve el valor lógico VERDADERO.
  1. Ir a la celda C5 / Escribir:

    =SI((SUMAPRODUCTO(N(RESIDUO(C3;FILA(INDIRECTO(“1:”&ENTERO(RAIZ(C3)))))=0))=1)=VERDADERO();”Es número PRIMO.”;”No es número primo.”)

    O también, escribir:

    =SI.ERROR(SI((SUMAPRODUCTO(N(RESIDUO(C3;FILA(INDIRECTO(“1:”&ENTERO(RAIZ(C3)))))=0))=1)=VERDADERO();”Es número PRIMO.”;”No es número primo.”);””), para evitar el error con el cero.
  2. Ir a la celda C3 / Escribir: 5. Mostrará en la celda C5 “Es número PRIMO”.

    Celda C5 mostrando Es número primo, por el valor en C3 de 5.
  3. Ir a la celda C3 / Escribir: 6. Mostrará en la celda C5 “No es número primo”.

    Celda C5 mostrando No es número primo, por el valor en C3 de 6.
  4. Aplicar el formato de celda y de fuente deseado, para mejorar la apariencia.

Calculadora de números primos en Excel

Nivel de dificultad: Básico Excel Básico

3 comentarios en “Calculadora de números primos en Excel.

  • Buenas, pues por más que lo intento la fórmula no me funciona. Sale el error #¿NOMBRE?. He repasado la formula detenidamente pero no hay manera. He probado en Excel 2010 y 365. Si no estoy equivocado, el error está en la formula INDIRECTO. Alguna sugerencia? Gracias.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.