Búsquedas avanzadas del número de celdas con texto, múltiples criterios Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Necesitamos conocer cuantas celdas con texto en el rango, coinciden con la condición dada, te mostramos las búsquedas avanzadas del número de celdas con texto, múltiples criterios Excel.

Búsquedas avanzadas del número de celdas con texto, múltiples criterios Excel

En nuestra hoja, disponemos de la columna A los nombre de clientes (en mayúsculas, minúsculas, con tilde, sin tilde y celdas vacías) y deseamos conocer cuantos clientes cumplen con el criterio deseado.

 A
1Nombre
2Ana
3José
4José Antonio
5María
6Marta
7María José
8JOSÉ
9Ángel
10Jose María
11Pepe
12Teresa
13José Carlos
14
15Juan/Jhon
  • CELDAS CON TEXTO

Muestra el número de celdas que contienen texto.

  1. Ir a: Celda D1 / Escribir:

    =CONTAR.SI(A2:A15;"*")
  2. Verificar como muestra 13 como el número de celdas (todas excepto A14, celda vacía).

  • CELDAS SIN TEXTO

Muestra el número de celdas que no contienen texto.

  1. Ir a: Celda D2 / Escribir:

    =CONTAR.SI(A2:A15; "<>*")
  2. Verificar como muestra 1 como el número de celdas sin texto (A14, celda vacía).

  • IGUAL A…

Muestra el número de celdas que contiene el valor igual a "josé" (con tilde), no discrimina mayúscula/minúscula.

  1. Ir a: Celda D3 / Escribir:

    =CONTAR.SI(A2:A15;"josé")

    O también,

    =CONTAR.SI(A2:A15;"=josé")
  2. Verificar como muestra 2 como el número de celdas que incluyen el valor igual a “José”, A3 y A8.

  • CONTIENE…

Muestra el número de celdas que contienen el valor "josé" (con tilde), en cualquier parte del texto, no discrimina mayúscula/minúscula.

  1. Ir a: Celda D4 / Escribir:

    =CONTAR.SI(A2:A15; "*josé*")
  2. Verificar como muestra 5 como el número de celdas que incluyen el valor José, José Antonio, María José, José María y José Carlos.

  • CONTIENE EL VALOR DE UNA CELDA…

Muestra el número de celdas que contienen el valor que incluye la celda A3.

  1. Ir a: Celda D5 / Escribir:

    =CONTAR.SI(A2:A15; "*"&A3&"*")
  2. Verificar como muestra 5 como el número de celdas que incluyen el valor José, José Antonio, María José, José María y José Carlos.

  • COMIENZA POR…

Muestra el número de celdas que comienzan por "josé" (con tilde), no discrimina mayúscula/minúscula.

  1. Ir a: Celda D7 / Escribir:

    =CONTAR.SI(A3:A16; "josé*")
  2. Verificar como muestra 4 como el número de celdas que incluyen el valor José, José Antonio, José María y José Carlos.

  • FINALIZA POR…

Muestra el número de celdas que finalizan por "josé" (con tilde), no discrimina mayúscula/minúscula.

  1. Ir a: Celda D8 / Escribir:

    =CONTAR.SI(A2:A15;"*José")
  2. Verificar como muestra 3 como el número de celdas que incluyen el valor José, María José, José.

  • POR NÚMERO DE CARACTERES…

Muestra el número de celdas con 5 carácteres de texto.

  1. Ir a: Celda D7 / Escribir:

    =CONTAR.SI(A2:A15;"?????")
  2. Verificar como muestra 3 como el número de celdas que incluyen el valor María, Marta y Ángel.

  • CON DETERMINADA LETRA EN POSICIÓN…

Muestra el número de celdas con la letra A como tercer carácter.

  1. Ir a: Celda D9 / Escribir:

    =CONTAR.SI(A2:A15; "??a*")
  2. Verificar como muestra 2 como el número de celdas que incluyen el valor An y Juan.

  • CON DETERMINADA LETRA EN POSICIÓN… (II)

Muestra el número de celdas con la letra T como penúltimo carácter.

  1. Ir a: Celda D8 / Escribir:

    =CONTAR.SI(A2:A15;"*a??")
  2. Verificar como muestra 1 como el número de celdas que incluyen el valor Marta.

  • CONTIENEN… (CON TILDE Y SIN ELLA)

Muestra el número de celdas que contienen José con tilde y sin ella, no discrimina mayúscula/minúscula.

  1. Ir a: Celda D8 / Escribir:

    =CONTAR.SI(A2:A15; "*jos*")
  2. Verificar como muestra 6 como el número de celdas que incluyen el valor José, José Antonio, María José, José, José María y José Carlos.

  • NOMBRE COMPUESTO QUE COMIENZA POR…

Muestra el número de celdas que contienen nombre compuesto que comienza por José (con tilde), no discrimina mayúscula/minúscula.

  1. Ir a: Celda D12 / Escribir:

    =CONTAR.SI(A2:A15; "José *")
  2. Verificar como muestra 2 como el número de celdas que incluyen el valor José Antonio, Jose María y José Carlos.

  • NOMBRE COMPUESTO QUE COMIENZA POR… (CON TILDE Y SIN ELLA)

Muestra el número de celdas que contienen nombre compuesto que comienza por José (con tilde y sin ella), no discrimina mayúscula/minúscula..

  1. Ir a: Celda D8 / Escribir:

    =CONTAR.SI(A2:A15; "Jos? *")
  2. Verificar como muestra 3 como el número de celdas que incluyen el valor José Antonio, Jose María y José Carlos.

  • CONTIENE ALGUNO DE LOS TÉRMINOS

Muestra el número de celdas que contienen nombre de "José" (con tilde) o "Pepe", no discrimina mayúscula/minúscula.

  1. Ir a: Celda D14 / Escribir:

    =CONTAR.SI(A2:A15; "*josé*")+CONTAR.SI(A2:A15; "*pepe*")
  2. Verificar como muestra 6 como el número de celdas que incluyen el valor José, José Antonio, María José, José María, Pepe y José Carlos.

  • CONTIENE UN TÉRMINO Y DISCRIMINA OTRO

Muestra el número de celdas que contienen nombre de "José" (con tilde) excepto "José Antonio", no discrimina mayúscula/minúscula.

  1. Ir a: Celda D15 / Escribir:

    =CONTAR.SI(A2:A15; "*josé*")-CONTAR.SI(A2:A15; "josé antonio")
  2. Verificar como muestra 4 como el número de celdas que incluyen el valor José, María José, José María y José Carlos.

  • CONTIENE ALGUNO DE LOS TÉRMINOS Y DISCRIMINA OTRO

Muestra el número de celdas que contienen nombre de "José" (con tilde) excepto "José Antonio", no discrimina mayúscula/minúscula.

  1. Ir a: Celda D16 / Escribir:

    =CONTAR.SI(A2:A15; "*josé*")+CONTAR.SI(A2:A15; "*pepe*")-CONTAR.SI(A2:A15; "josé antonio")
  2. Verificar como muestra 5 como el número de celdas que incluyen el valor José, María José, José María, Pepe y José Carlos.

  • CELDAS NO VACÍAS

Muestra el número de celdas que contienen algún valor.

  1. Ir a: Celda D17 / Escribir:

    =CONTAR.SI(A2:A15; "<>" &"")
  2. Verificar como muestra 13 como el número de celdas que incluyen el valor, todas excepto A14 (vacía) .

  • NO CONTIENE

Muestra el número de celdas que no contienen "josé" con tilde, no discrimina mayúscula/minúscula.

  1. Ir a: Celda D18 / Escribir:

    =CONTAR.SI(A2:A13; "<>josé")
  2. Verificar como muestra 10 como el número de celdas que incluyen el valor Ana, José Antonio, María, Marta, María José, Ángel, Jose María, Pepe, Teresa, José Carlos y Juan

  • CONTIENE COMO PRIMERA LETRA LA A HASTA LA INDICADA

Muestra el número de celdas que comienzan con la A hasta la J, no discrimina mayúscula/minúscula.

  1. Ir a: Celda D18 / Escribir:

    =CONTAR.SI(A2:A15;"<j")
  2. Verificar como muestra 2 como el número de celdas que incluyen el valor Ana y Ángel.

  • CONTIENE COMO PRIMERA LETRA LA INDICADA HASTA LA Z

Muestra el número de celdas que comienzan con la J hasta la Z, no discrimina mayúscula/minúscula.

  1. Ir a: Celda D18 / Escribir:

    =CONTAR.SI(A2:A15; ">j")
  2. Verificar como muestra 11 como el número de celdas que incluyen el valor José, José Antonio, María, Marta, María José, José, Jose María, Pepe, Teresa y Juan.

  • NO FINALIZA POR

Muestra el número de celdas que no contienen é (e con tilde al final), no discrimina mayúscula/minúscula.

  1. Ir a: Celda D18 / Escribir:

    =CONTAR.SI(A2:A13; "<>*é")
  2. Verificar como muestra 9 como el número de celdas que incluyen el valor Ana, José Antonio, María, Marta, María José, Ángel, José María, Teresa, José Carlos y Juan.

  • CONTIENE SÍMBOLO

Muestra el número de celdas que contienen el símbolo /.

  1. Ir a: Celda D22 / Escribir:

    =CONTAR.SI(A2:A15;"*~/*")
  2. Verificar como muestra 1 como el número de celdas que incluyen el valor Juan/Jhon.

  • CONTIENE SÍMBOLO Y VALOR

Muestra el número de celdas que contienen el símbolo / seguido de Jhon, no discrimina mayúscula/minúscula.

  1. Ir a: Celda D23 / Escribir:

    =CONTAR.SI(A3:A16;"*~/*jhon")
  2. Verificar como muestra 1 como el número de celdas que incluyen el valor Juan/Jhon.

  

Nivel de dificultad: Avanzado Excel Avanzado

2 comentarios en “Búsquedas avanzadas del número de celdas con texto, múltiples criterios Excel

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *