BUSCARV (VLOOKUP) en diferentes rangos de Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Podemos buscar mediante la función BUSCARV (VLOOKUP) en diferentes rangos de Excel.

BUSCARV (VLOOKUP) en diferentes rangos de Excel

Emplearemos las siguientes funciones anidándolas:

  • Función SI.ERROR. Muestra un valor si la expresión es un error y el valor de la expresión no lo es.

  • Función BUSCARV. Busca en la primera columna de una matriz y se mueve en la fila para devolver el valor de una celda.

Disponemos del país y el importe en los rangos B:C, E:F y H:I. Y deseamos buscar el importe según el nombre del país.

  1. Ir a la celda L2 / Escribir:

    =SI.ERROR(BUSCARV(K2;B3:C6;2;0);SI.ERROR(BUSCARV(K2;E3:F6;2;0);BUSCARV(K2;H3:I6;2;0 )))
  2. Ir a la celda K2 / Escribir: España. O el país deseado.

  3. Verificar como en L2 se muestra 12.500 como el importe de España.

     

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *