BUSCARV (VLOOKUP) con varios criterios en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Al utilizar BUSCARV (VLOOKUP) en Excel, aplicamos un criterio de búsqueda, pero podemos emplear varios criterios.

BUSCARV (VLOOKUP) con varios criterios en Excel

En la columna B disponemos del nombre del delegado, en la columna C la ciudad y en la columna D el importe.

ABCD
1NombreCiudadImporte
2JuanMadrid12.600
3AnaSevilla8.600
4MaríaBilbao14.500
5JuanOviedo8.750
6AnaValencia10.900
  • COLUMNA AUXILIAR

Creamos una columna auxiliar, delante de los datos.

  1. Ir a: Celda A2 / Escribir:

    =B2&C2
  2. Copiar la celda A2 / Pegar en el rango A3:A6.

  • BUSCARV
  1. Ir a: Celda H2 / Escribir:

    =BUSCARV(F2&G2;A2:D6;4;FALSO)

    O también, para evitar el error #N/A:

    =SI.ERROR("=BUSCARV(F2&G2;A2:D6;4;FALSO)";"")
  • VALORES A BUSCAR
  1. Ir a: Celda F2 / Escribir: Juan. O el nombre deseado.

  2. Ir a: Celda G2 / Escribir: Oviedo. O la ciudad deseada.

  3. Verificar como muestra 8.750 como el valor de la fila 5 (Juan / Oviedo).

Nivel de dificultad: Básico Excel Básico

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.