BUSCARV en varias hojas Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Podemos aplicar la función BUSCARV en varias hojas Excel, para que nos busque información en diferentes hojas del libro de Excel. Para ello deberemos de anidar las funciones SI, ESNOD y BUSCARV que oculta el error #N/A.

Deseamos buscar el número de teléfono de nuestros contactos, para ello disponemos de diferentes hojas de la A a la Z y en su interior las personas ordenadas por su inicial.

Emplearemos las siguientes funciones, anidándolas:

  • Función SI. Evalúa si se cumple una condición.
  • Función ESNOD. Devuelve VERDADERO si el valor es el valor de error #N/A (valor no aplicable).
  • Función BUSCARV. Busca en la primera columna de una matriz y se mueve en la fila para devolver el valor de una celda.
  • Ir a: Hoja2 / Escribir datos de prueba, nombres con letra A.
    BUSCARV en varias hojas Excel: Hoja2 con contacto y teléfono (Columna A y B).
  • Ir a: Hoja3 / Escribir datos de prueba, nombres con letra B.
    BUSCARV en varias hojas Excel: Hoja3 con contacto y teléfono (Columna A y B).
  1. Ir a: Hoja1 / Celda D2 / Escribir: Blanca. O la persona de búsqueda deseada.

  2. Ir a: Celda E2 / Escribir:

=SI(ESNOD(BUSCARV(D2;Hoja1!A:B;2;0)); SI(ESNOD(BUSCARV(D2;Hoja2!A:B;2;0)); BUSCARV(D2;Hoja3!A:B;2;0); BUSCARV(D2;Hoja2!A:B;2;0)); BUSCARV(D2;Hoja1!A:B;2;0)).

Fórmula que buscará el número de teléfono por el nombre de la persona de contacto (D2).

BUSCARV en varias hojas Excel: Hoja1 con contacto en celda D2 y BUSCARV en celda E2.

La fórmula incluirá tantas expresiones como hojas donde buscar, así como la referencia de su nombre.

Así podemos aplicar BUSCARV en varias hojas Excel del libro, ocultando el error #N/A.

- Consultar:

BuscarV diferenciando mayúsculas y minúsculas

Mensaje de error BuscarV

Nivel de dificultad: Avanzado Excel Avanzado

32 comentarios en “BUSCARV en varias hojas Excel

  • Ayuda:
    Estoy tratando de hacer una hoja Máster, en donde por el número de empleado, pueda darme los resultados de todos los cursos que a tomado (fechas de validación, fechas de vencimiento, etc.). Cada curso está en una hoja diferente, y en cada hoja están todos los empleados.

    Ayuda, que fórmula necesito, no recuerdo y no logro hacer eso.

  • como aplicar esta formula en suma de 9 hojas o mas; porque se aplica snod dos veces y luego solo buscarv.

    • Hola Juan de dios,

      La fórmula para aplicar a 9 hojas será:

      =SI(ESNOD(BUSCARV(D2;Hoja1!A:B;2;0));
      SI(ESNOD(BUSCARV(D2;Hoja2!A:B;2;0));
      SI(ESNOD(BUSCARV(D2;Hoja3!A:B;2;0));
      SI(ESNOD(BUSCARV(D2;Hoja4!A:B;2;0));
      SI(ESNOD(BUSCARV(D2;Hoja5!A:B;2;0));
      SI(ESNOD(BUSCARV(D2;Hoja6!A:B;2;0));
      SI(ESNOD(BUSCARV(D2;Hoja7!A:B;2;0));
      SI(ESNOD(BUSCARV(D2;Hoja8!A:B;2;0));
      SI(ESNOD(BUSCARV(D2;Hoja9!A:B;2;0));
      SI(ESNOD(BUSCARV(D2;Hoja10!A:B;2;0));
      BUSCARV(D2;Hoja10!A:B;2;0));
      BUSCARV(D2;Hoja9!A:B;2;0));
      BUSCARV(D2;Hoja8!A:B;2;0));
      BUSCARV(D2;Hoja7!A:B;2;0));
      BUSCARV(D2;Hoja6!A:B;2;0));
      BUSCARV(D2;Hoja5!A:B;2;0));
      BUSCARV(D2;Hoja4!A:B;2;0));
      BUSCARV(D2;Hoja3!A:B;2;0));
      BUSCARV(D2;Hoja2!A:B;2;0));
      BUSCARV(D2;Hoja1!A:B;2;0))

      Y recuerda verifica el código y es necesario que el libro tenga 10 hojas.
      Realmente hay 2 secuencias para cada hoja:
      1. SI(ESNOD(BUSCARV(D2;Hoja1!A:B;2;0));
      2. BUSCARV(D2;Hoja1!A:B;2;0))

      Y recuerda que según Microsoft: "Aunque Excel permite anidar hasta 64 funciones SI diferentes, no se recomienda hacerlo."

      Saludos.

  • ejemplo: si en la hoja1 tengo la columna id que coincide con la hoja2 con la misma columna id, como hago para que compare si las id de los dos libros son iguales me copee el numero de teléfono en la hoja 1?

  • ejemplo: tengo una solapa una columna que es todo soja, mas SFA, mas fechas, lo que quisiera hacer en otra solapa quisiera llevar esa SOJA diferenciado por fecha y SFA, si una fecha X no aparece SFA no deberia de estirarme la SOJA en la otra solapa

  • Muy buena explicación y muy ilustrativa voy a probarla pero considero que me va a funcionar demasiado, felicidades por tu aportación !!!!

  • Hola , he tratado de hacer lo que indicas, pero con solo 2 hojas (una lista en cada una de ellas) no logro que busque en ambas hojas, solo me muestra los resultados correctos de la primera hoja. (ESTA ES LA FORMULA USADA):

    =SI(ESNOD(D2;HOJA1!A:B;2;0));SI(ESNOD(D2;HOJA2!A:B;2;0));BUSCARV(D2;HOJA2!A:B;2;0));BUSCARV(D2;HOJA1!A:B;2;0))

    Saludos

    • Hola ALvaro,

      Por favor revisa la fórmula: =SI(ESNOD(BUSCARV(D2;Hoja1!A:B;2;0)); SI(ESNOD(BUSCARV(D2;Hoja2!A:B;2;0)); BUSCARV(D2;Hoja3!A:B;2;0); BUSCARV(D2;Hoja2!A:B;2;0)); BUSCARV(D2;Hoja1!A:B;2;0)).

      No incluyes la función BUSCARV.

      Saludos.

  • Me encantó! muchas gracias por la ayuda!! Mi problema es que tengo hoja 1 (buscador) y otras 3 planillas mas. Con este ejemplo, tengo problemas para que busque en la última hoja (hoja4)

  • Hola. En la hoja 1 tengo los datos de las familias organizados por número de familia (columna 1) y en la hoja 2 tengo los datos de sus integrantes organizados por número de documento (columna 1). En una tercera hoja debo buscar la dirección de un integrante ingresando el número de documento, de forma que al cambiar el número de documento cambie la dirección. La dirección está en la hoja 1 y el documento en la hoja 2. Cómo hago? No vale que me digan que ponga todo en una misma hoja. Es para resolver un ejercicio. Debo resolverlo así.

  • Me pudieran apoyar para ver que estoy haciendo mal en esta formula.

    +if(ISNA(VLOOKUP(F2,SPEI!E1:J38,6,0))+IF(ISNA(VLOOKUP(f2,tERCEROS!D1:H23,5,0))+VLOOKUP(f2,SPEI!E4:J38,6,0)+VLOOKUP(tERCEROS!D1:H23,5,0)))

    • Hola Mauro,

      Realmente no se que es lo que intentas hacer, la fórmula presenta error ya que la función IF no tiene argumentos. Se muestra la misma suma de VLOOKUP para 2 resultados y la misma suma con ISNA.

      Saludos.

  • Hola tengo un listado en HOJA 1 y luego tengo 100 (literal) tabs. El objetivo es completar la hoja 1 con las 100 tabs restantes. Si uso lo que explicas, debo replicar la formula 100 veces y quizas al mes siguiente no me sirva porque la cantidad de solapas varia. Hay alguna forma para que se haga masivo?

  • HOLA buenos dias, requiero comprara 2 hojas de un libro para que excell compare los numeros de cedula de las dos hojas y me aroje finalmente cedula y nombre que esten en las dos hojas, como hago la formula?

  • Hola. He tratado de aplicarlo, no sale ¿Puedes ver qué está mal?

    =SI(ESNOD(BUSCARV($C7;Datos!$V$7:$W$600;2;0));SI(ESNOD(BUSCARV($C7;Fichas!$A$7:$F$600;2;0));BUSCARV($C7;Fichas!$A$7:$F$600;2;0));BUSCARV($C7;Datos!$V$7:$W$600;2;0))

  • Me gusto muy bien explicado, pero lo que busco es poder cambiar la hoja de búsqueda, por decir tengo varias hojas con los meses del año (enero, febreo, etc), y necesito revisar los horarios, de enero de una persona, y luego cambiar a marzo y despues cambiar persona, si tienen alguna idea se los agradeceria

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.