BUSCARV en varias hojas Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Podemos aplicar la función BUSCARV en varias hojas Excel, para que nos busque información en diferentes hojas del libro de Excel. Para ello deberemos de anidar las funciones SI, ESNOD y BUSCARV que oculta el error #N/A.

Deseamos buscar el número de teléfono de nuestros contactos, para ello disponemos de diferentes hojas de la A a la Z y en su interior las personas ordenadas por su inicial.

Emplearemos las siguientes funciones, anidándolas:

  • Función SI. Evalúa si se cumple una condición.

  • Función ESNOD. Devuelve VERDADERO si el valor es el valor de error #N/A (valor no aplicable).

  • Función BUSCARV. Busca en la primera columna de una matriz y se mueve en la fila para devolver el valor de una celda.

  • Ir a: Hoja2 / Escribir datos de prueba, nombres con letra A.
    BUSCARV en varias hojas Excel: Hoja2 con contacto y teléfono (Columna A y B).
  • Ir a: Hoja3 / Escribir datos de prueba, nombres con letra B.
    BUSCARV en varias hojas Excel: Hoja3 con contacto y teléfono (Columna A y B).
  1. Ir a: Hoja1 / Celda D2 / Escribir: Blanca. O la persona de búsqueda deseada.

  2. Ir a: Celda E2 / Escribir:

=SI(ESNOD(BUSCARV(D2;Hoja1!A:B;2;0)); SI(ESNOD(BUSCARV(D2;Hoja2!A:B;2;0)); BUSCARV(D2;Hoja3!A:B;2;0); BUSCARV(D2;Hoja2!A:B;2;0)); BUSCARV(D2;Hoja1!A:B;2;0)).

Fórmula que buscará el número de teléfono por el nombre de la persona de contacto (D2).

BUSCARV en varias hojas Excel: Hoja1 con contacto en celda D2 y BUSCARV en celda E2.

La fórmula incluirá tantas expresiones como hojas donde buscar, así como la referencia de su nombre.

Así podemos aplicar BUSCARV en varias hojas Excel del libro, ocultando el error #N/A.

 

– Consultar: BuscarV diferenciando mayúsculas y minúsculas.

– Consultar: Eliminar mensaje de error en BuscarV.

– Consultar: Otras alternativas a BuscarV.

Nivel de dificultad: Avanzado Excel Avanzado

6 comentarios en “BUSCARV en varias hojas Excel

  • Ayuda:
    Estoy tratando de hacer una hoja Máster, en donde por el número de empleado, pueda darme los resultados de todos los cursos que a tomado (fechas de validación, fechas de vencimiento, etc.). Cada curso está en una hoja diferente, y en cada hoja están todos los empleados.

    Ayuda, que fórmula necesito, no recuerdo y no logro hacer eso.

  • como aplicar esta formula en suma de 9 hojas o mas; porque se aplica snod dos veces y luego solo buscarv.

    • Hola Juan de dios,

      La fórmula para aplicar a 9 hojas será:

      =SI(ESNOD(BUSCARV(D2;Hoja1!A:B;2;0));
      SI(ESNOD(BUSCARV(D2;Hoja2!A:B;2;0));
      SI(ESNOD(BUSCARV(D2;Hoja3!A:B;2;0));
      SI(ESNOD(BUSCARV(D2;Hoja4!A:B;2;0));
      SI(ESNOD(BUSCARV(D2;Hoja5!A:B;2;0));
      SI(ESNOD(BUSCARV(D2;Hoja6!A:B;2;0));
      SI(ESNOD(BUSCARV(D2;Hoja7!A:B;2;0));
      SI(ESNOD(BUSCARV(D2;Hoja8!A:B;2;0));
      SI(ESNOD(BUSCARV(D2;Hoja9!A:B;2;0));
      SI(ESNOD(BUSCARV(D2;Hoja10!A:B;2;0));
      BUSCARV(D2;Hoja10!A:B;2;0));
      BUSCARV(D2;Hoja9!A:B;2;0));
      BUSCARV(D2;Hoja8!A:B;2;0));
      BUSCARV(D2;Hoja7!A:B;2;0));
      BUSCARV(D2;Hoja6!A:B;2;0));
      BUSCARV(D2;Hoja5!A:B;2;0));
      BUSCARV(D2;Hoja4!A:B;2;0));
      BUSCARV(D2;Hoja3!A:B;2;0));
      BUSCARV(D2;Hoja2!A:B;2;0));
      BUSCARV(D2;Hoja1!A:B;2;0))

      Y recuerda verifica el código y es necesario que el libro tenga 10 hojas.
      Realmente hay 2 secuencias para cada hoja:
      1. SI(ESNOD(BUSCARV(D2;Hoja1!A:B;2;0));
      2. BUSCARV(D2;Hoja1!A:B;2;0))

      Y recuerda que según Microsoft: “Aunque Excel permite anidar hasta 64 funciones SI diferentes, no se recomienda hacerlo.”

      Saludos.

  • ejemplo: si en la hoja1 tengo la columna id que coincide con la hoja2 con la misma columna id, como hago para que compare si las id de los dos libros son iguales me copee el numero de teléfono en la hoja 1?

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *