BuscarV con dos criterios en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

En muchas ocasiones necesitamos aplicar BUSCARV con dos criterios de búsqueda en Excel.

BuscarV con dos criterios de búsqueda en Excel

Emplearemos las siguientes funciones anidándolas:

  • Función INDICE. Devuelve un valor o referencia de la celda en la intersección de una fila y columna de un rango.

  • Función COINCIDIR. Devuelve la posición relativa de un elemento en una matriz, que coincide con un valor dado en el orden especificado.

  • Función SI. Comprueba si se cumple una condición y devuelve un valor si se evalúa como verdadero y otro valor si se evalúa como falso.

 

En el rango A1:C6 disponemos del origen de datos, donde buscar por la columna A y B para obtener C.

 ABC
1NombreCiudadImporte
2JuanMadrid12.600
3AnaSevilla8.600
4MaríaBilbao14.500
5JuanOviedo8.750
6AnaValencia10.900
  1. Ir a: Celda F3 / Escribir:

    =INDICE(C2:C6;COINCIDIR(F1;SI(B2:B6=F2;A2:A6);0))
  2. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=INDICE (C2:C6 ;COINCIDIR (F1; SI( B2:B6= F2; A2:A6) ;0))}.

    O también, para no mostrar el error si no encuentra datos:

    =SI.ERROR(INDICE(C2:C12;COINCIDIR(F1;SI(B2:B12=F2;A2:A12);0));"")
  3. Ir a: Celda F1 / Escribir: Juan. O el nombre deseado.

  4. Ir a: Celda F2 / Escribir: Oviedo. O la ciudad deseada.

  5. Verificar como muestra 8750 como el importe aplicado a Juan de Oviedo.

    Como siempre en BUSCARV no se admiten valores repetidos.

Celda F3 con el valor buscado de F1 y F2

- Ampliar información: BuscarV con varios criterios.

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.