BuscarV con coincidencia cercana en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Cuando trabajamos con la función BUSCARV generalmente buscamos la coincidencia exacta del valor buscado, pero en ocasiones es interesante aplicar BUSCARV con coincidencia cercana en Excel.

BuscarV con coincidencia cercana en Excel
En nuestra empresa aplicamos una promoción de descuento según la franja de edad del cliente, así en la columna G insertamos el rango de edad (De 0 a 19, De 20 a 49, De 50 a 69 y mayor de 70 años) y en la columna H el descuento aplicado.

BuscarV con coincidencia cercana en Excel: Columna G con franja de edades y columna H con el descuento aplicado.

En la columna A insertamos el nombre del cliente, columna B insertamos su edad y en la columna C el importe de la venta.

BuscarV con coincidencia cercana en Excel: Columna B con edad del cliente, columna C importe de la venta.
  1. ORDENAR G. Clic sobre cualquier celda de la columna G. Importante ordenar la columna de manera ascendente.

  2. Ir a: Cinta de opciones / Pestaña: Datos / Grupo: Ordenar y filtrar / Ordenar de menor a mayor. Ordenará el rango G:H para poder realizar la búsqueda.

  3. DESCUENTO. Ir a: Celda D2 / Escribir:

    =BUSCARV(B2;$G$2:$H$5;2;1)

    O también desde el asistente de funciones, Ir a: Cinta opciones / Fórmulas / Biblioteca de funciones / Búsqueda y referencia / BUSCARV.

    B2 será el valor buscado (Edad), $G$2:$H$5 como referencia absoluta será donde buscar, 2 indica la columna H del descuento y 1 indica la coincidencia más cercana.

  4. Copiar la celda D2. Celda con la función.

  5. Seleccionar el rango D3:D10 / Pegar como fórmula.

  6. TOTAL. Ir a: Celda E2 / Escribir:

    =(B2*C2)-((B2*C2)*D2)
  7. Copiar la celda E2. Celda con la función.

  8. Seleccionar el rango E3:E10 / Pegar como fórmula.

BuscarV con coincidencia cercana en Excel: Columna D con el descuento obtenido de columna H , según la referencia de B.

Así mediante la función BUSCARV con coincidencia cercana en Excel, podemos trabajar con rango de datos.

Nivel de dificultad: Avanzado Excel Avanzado

2 comentarios en “BuscarV con coincidencia cercana en Excel

  • ayuda con esto: imaginen en exce estas celdas con estos valores: A1 (18990), B1 (19350), C1 (19903), en la celda D1 tengo el valor a buscar (referencia) de 19000, entonces en la celda E1, necesito un buscar H que me diga que la celda menor o igual a D1 es en este caso B1, la mas cercana y menor.. gracias

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *