Buscar y Ordenar datos con función en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Disponemos de un listado con las ventas de los comerciales, y deseamos obtener en orden las ventas de mayor a menor, es decir, buscar y ordenar datos en Excel.

Buscar y Ordenar datos con función en Excel
El origen de datos puede estar en una archivo externo y para facilitar la compresión se realiza en la misma hoja.

Emplearemos las siguientes funciones anidándolas:

  • Función JERARQUIA. Devuelve la jerarquía de un número en una lista de números.

  • Función CONTAR.SI. Cuenta el número de celdas que no están en blanco dentro de un rango que coincida con los criterios especificados.

  • Función BUSCARV. Busca en la primera columna de una matriz y se mueve en la fila para devolver el valor de una celda.

  • Función DESREF. Devuelve un desplazamiento de referencia a partir de una referencia determinada.

  • Función COINCIDIR. Busca los valores en una referencia o matriz.

  • Función K.ESIMOMENOR. Devuelve el k-ésimo menor valor de un conjunto de datos.

  • Función FILA. Devuelve el número de fila de una referencia.

Disponemos el origen de los datos con el comercial y las ventas mensuales:

 AB
1ComercialVentas
2Vicente8.750,00
3Juan12.375,00
4Roberto6.500,00
5María José21.350,00
6Ramón11.200,00
7Ana9.800,00
8Marísa7.950,00
9Marta11.500,00
10Juan José9.800,00
  1. JERARQUÍA. Ir a: Celda C2 / Escribir:

  2. =JERARQUIA(B2;$B$2:$B$10;0)+CONTAR.SI($B$2:B2;B2)-1
  3. Copiar la celda C2 / Pegarla en el rango C3:C10.

  4. Buscar y Ordenar datos: Rango C2:C10 con función anidada JERARQUIA y CONTAR.SI
  5. POSICIÓN. Ir a: Celda E2 / Escribir:

  6. =BUSCARV(F2;$A$2:$C$10;3;FALSO)
  7. Copiar la celda E2 / Pegarla en el rango E3:E10.

  8. COMERCIAL. Ir a: Celda F2 / Escribir:

  9. =DESREF(A$2;COINCIDIR(K.ESIMO.MENOR(C$2:C$10;FILA()-FILA(C$2)+1);C$2:C$10;0)-1;0)
  10. Copiar la celda F2 / Pegarla en el rango F3:F10.

  11. VENTAS. Ir a: Celda G2 / Escribir:

  12. =BUSCARV(F2;$A$2:$B$10;2;FALSO)
  13. Copiar la celda G2 / Pegarla en el rango G3:G10.

Buscar y Ordenar datos en Excel: Columna E con posición, F Nombre comercial y G importe ventas

Mediante funciones podemos buscar y ordenar datos en Excel.

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *