Buscar valores repetidos por criterio en columna Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

Con BUSCARV podemos buscar valores únicos sin criterios, pero nos puede interesar buscar valores repetidos por criterio en columna Excel.

Buscar valores repetidos por criterio en columna Excel

Emplearemos las siguientes funciones anidándolas:

  • Función INDICE. Devuelve una valor de la celda en la intersección de una fila y columna en particular, en un rango especificado.
  • Función COINCIDIR. Devuelve la posición relativa de un elemento en la matriz, que coincide con un valor dado en el orden especificado.

En la columna A disponemos del nombre del delegado, en la columna B sus países y en la columna C el importe de las ventas. Y deseamos buscar el delegado en los países deseados.

 ABC
1NombrePaísImporte
2AnaEspaña1.500
3LuisPerú675
4RamónEspaña1.100
5AnaChile824
6LuisCosta Rica475
7BelénArgentina2.100
8AnaColombia1.200
9MaríaVenezuela679
10LuisColombia900
 
  • CRITERIOS
  1. Ir a: Celda E2 / Escribir: Ana. O el nombre deseado para la búsqueda.

  2. Ir a: Celda F1 / Escribir: España. O el país del primer criterio.

  3. Ir a: Celda G1 / Escribir: Colombia. O el país del segundo criterio.

  4. Ir a: Celda H1 / Escribir: Chile. O el país del tercer criterio.

 
  • FUNCIÓN DE BÚSQUEDA
  1. Ir a: Celda F2 / Escribir como fórmula matricial:

    =INDICE($C$2:$C$10; COINCIDIR(1;($E2=$A$2:$A$10)* (F$1=$B$2:$B$10); 0))

  2. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=INDICE($C$2:$C$10; COINCIDIR(1;($E2=$A$2:$A$10)* (F$1=$B$2:$B$10); 0))}

  3. Copiar la celda F2 y pegar en el rango G2:H2. Verificar como muestra los resultados según el criterio de la fila y columna.

Rango F2:H2 con los valores buscados por el delegado y según los países.
Nivel de dificultad: Avanzado Excel Avanzado

2 comentarios en “Buscar valores repetidos por criterio en columna Excel

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.