Buscar valores repetidos con múltiples resultados en BUSCARV Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010

En muchas ocasiones necesitamos buscar valores repetidos con múltiples resultados en BUSCARV Excel

Buscar valores repetidos con múltiples resultados en BUSCARV Excel

Disponemos en la columna B los nombres de los clientes y en la columna C el importe de las ventas.

 ABC
1 NombreImporte
2 Lola1200
3 Juan3500
4 Ana2100
5 Lola875
6 Rosa1500
7 Ana850
8 Lola425
9 María975
10 Javier1200
11 Lola4200
  • COLUMNA AUXILIAR

Creamos una columna auxiliar para mostrar el nombre con el número de posición.

  1. Ir a: Celda A2 / Escribir:

    =B2&CONTAR.SI($B$1:B2;B2)
  2. Copiar la celda A2 / Pegar en el rango A3:A11.

  3. Verificar como se muestra el nombre con el dígito del número de repetición (Lola = Lola 1; Lola 2; Lola 3...).

Rango A2:A11 con columna auxiliar de referencia
  • RESULTADOS

  1. Ir a: Celda E5 / Escribir 1. Como primera repetición.

  2. Ir a: Celda E6 / Escribir 2. Como segunda repetición.

  3. Ir a: Celda E7 / Escribir 3. Como tercera repetición.

  4. Ir a: Celda E8 / Escribir 4. Como cuarta repetición.

  5. Ir a: Celda E9 / Escribir 5. Como quinta repetición.

  6. Ir a: Celda E10 / Escribir 6. Como sexta repetición.

  7. Ir a: Celda E11 / Escribir 7. Como septima repetición.

    Rango E5:E11 con numeración de repetición
  8. Ir a: Celda F5 / Escribir:

    =SI.ERROR(BUSCARV($F$1&E5;$A$1:$C$12;3;0);"")
  9. Copiar la celda F5 / Pegar en el rango F6:F11.

    Rango F5:F11 con valor buscado según la posición
  10. Ir a: Celda F2 / Escribir:

    =SUMA(F5:F11)
  11. Ir a: Celda F1 / Escribir: Lola. O el nombre deseado para buscar los resultados.

  12. Hoja Excel con el número de resultados para el nombre Lola
  13. Ir a: Verificar como muestra 4 resultados para el comercial Lola.

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.