Buscar datos con BuscarV y sumar valores en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

En un rango de datos, necesitamos buscar un valor y sumar todos los datos de una condición mediante funciones, similar al empleo de las tablas dinámicas.

Buscar datos con BuscarV y sumar valores en Excel

Emplearemos las siguientes funciones anidándolas:

  • Función SUMA. Suma todos los números en un rango, en nuestro caso indicamos la columna.

  • Función BUSCARV. Busca en la primera columna de una matriz y se mueve en la fila para devolver el valor de una celda.

    La fúnción anidada se deberá insertar como fórmula matricial.

buscasuma04

 

Disponemos de un rango con datos cruzados, las filas muestran el año y las columnas diferentes países y deseamos buscar por el año deseado y algunos de los países.

 ABCDEFG
1EspañaMéxicoFranciaColombiaAlemaniaPerú
22016123456
3201524681012
42014369121518
  • IMPORTE EUROPA – 2016

  1. Ir a: Celda B7 / Escribir: 2016. Como el año que deseamos buscar para los valores de Europa.

  2. Ir a: Celda C7 / Escribir:

    =SUMA(BUSCARV(B7;A1:G4;{2;4;6};0))
  3. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=SUMA(BUSCARV(B7;A1:G4;{2;4;6};0))}.

  4. Mostrará 9 como la suma en el año 2016 para España, 1; Francia, 3 y Alemania 5.

buscasuma01
  • IMPORTE AMÉRICA – 2014

  1. Ir a: Celda B8 / Escribir: 2014. Como el año que deseamos buscar para los valores de América.

  2. Ir a: Celda C8 / Escribir:

    =SUMA(BUSCARV(B8;A1:G4;{3;5;7};0))
  3. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=SUMA(BUSCARV(B8;A1:G4;{3;5;7};0))}.

  4. Mostrará 36 como la suma en el año 2016 para México, 6; Colombia, 12 y Perú 18.

buscasuma02
  • IMPORTE TOTAL – 2015

  1. Ir a: Celda B9 / Escribir: 2015. Como el año que deseamos buscar para todos los valores.

  2. Ir a: Celda C9 / Escribir:

    =SUMA(BUSCARV(B9;A1:G4;{2;3;4;5;6;7};0))
  3. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=SUMA(BUSCARV(B9;A1:G4;{2;3;4;5;6;7};0))}.

  4. Mostrará 42 como la suma en el año 2015 para España, 2; México, 4, Francia, 6, Colombia, 8, Alemania 10 y Perú 12.

buscasuma03
Nivel de dificultad: Avanzado Excel Avanzado

39 comentarios en “Buscar datos con BuscarV y sumar valores en Excel

    • Hola Gustavo,

      Basándonos en el mismo ejemplo, insertamos la fórmula:

      =SUMA(BUSCARV(A2;A2:D4;3;0))+SUMA(BUSCARV(A4;A2:D4;3;0))

      El primer valor corresponde a México 2016 y el segundo a México 2014.

      Saludos.

  • Hola,
    tengo una consulta, y si en una de las celdas hubiera texto, por ejemplo quisiera agregarle el simbolo de la moneda, $, USD, EUR, o el texto que sea (por unidad, no se en realidad que se esta sumando en el ejemplo) como se haría para que sume numeros y agregue el texto en una misma celda?

    • Hola Belén,

      Respecto a que está sumando el ejemplo, lee el apartado 4 de los diferentes casos y ahí lo indica.

      Para asignar el tipo de moneda según el país se puede realizar con la función SI anidada, que evalúe el país y asigne su moneda.

      Saludos.

  • Hola, buenos días, esta combinación es barbara, el tema que la necesito para que sume 2 columnas pero en la busqueda de otro libro, y se que suma en otro libro (que está cerrado), no funciona,
    Consulta, conocen alguna función que haga lo mismo que este ejemplo pero de otro libro (si está cerrado mejor).

    Muchísimas gracias!!!!!

    Daniel.

  • Hola!
    Gracias por el excelente post. Sin embargo, tengo una pregunta.
    Normalmente en el “indicador columnas”, damos los números correspondientes a las columnas que queremos sumar
    e.g. Importe Europa {2;4;6}
    Existe alguna manera de obtener aquellos números {2;4;6} automáticamente y que sean válidos para la sintaxis completa?
    Lo intenté con {COINDIDIR;COINCIDIR;COINCIDIR} pero no me funcionó.

  • Excelente ejemplo!!! Pero me queda una duda:

    Como puedo sumar valores que se encuentran en la misma columna, como la pregunta que hicieron más arriba de México, pero con la particularidad de que exista más de un valor para, por ejemplo, el año 2014. No tiene mucho sentido el ejemplo pero para el caso que lo quiero aplicar si lo tiene (personas que se atienden en un mismo lugar, misma ID)

    Saludos,

  • ESTIMADO CONSULTA,
    PARA REALIZAR UNA BUSQUEDA Y AL VALOR ENCONTRADO SUMARLE UN VALOR COMO SE PUEDE HACER?

    POR EJEMPLO ME PIDEN BUSCAR EN UNA PLANILLA DE REMUNERACIONES EL NOMBRE DE UNA PERSONA X, Y SABER CUANTO ES EL LIQUIDO QUE VA A RECIBIR PERO A ESO SUMARLE UN BONO? ALGUNA FUNCION QUE LO HAGA?

  • Buenos días, disculpa pero la funcion no me funciona, tengo Excel 2013 y no se si es que la estoy copiando mal o sera que deshabilitaron la funcion, en espera de su pronta respuesta de verdad me interesa mucho esta combinacion de funciones.

    • Hola Daniel,

      Si tienes Excel en español, todo es igual. Es importante insertar la función como matricial, como se indica en los puntos 3. Escribes la función sin pulsar Enter/ni clic en ninguna celda, pulsas Ctrl+Shift+Enter y listo.

      Saludos.

  • Buen día,

    Excelente explicación, pero si lo quiero hacer sumando el valor que tenga en varias filas de un mismo concepto como se debe hacer la formula

  • Buenas,
    No se si lo que voy a preguntar se puede hacer…
    A ver yo tengo unos numero de clientes, los cual pongo en una columna el numero y en la otra el nombre. Estos clientes los introduzco varias veces con un importe en varias columnas, Quiero que en una celda busque al cliente x y sume todas los importes que hay en la columna b, columna c y columna j… Y así porque hay alguna columnas mas…

    Esto lo puedo hacer haciendo un bucarv y que sume lo que le pido?

    Juver

  • La llave de busqueda es el numero de documento y este se repite en varias filas con valores diferentes, y quisiera tener una lista de numeros de documentos y en frente la suma total de los valores por N° de documento.

    Alguien me puede colaborar con esta formula?

  • Hola desde Colombia.

    Podrias explicar la parte de la formula:

    =BUSCARV(B7;A1:G4;{2;4;6};0)

    Especificamente el “Indicador de columna o valor regresado” {2;4;6}

    • Hola Gabriel,

      {2;4;6} Indica el número de las columnas 2= España(B); 4= Francia(D) y 6= Alemania(F); Son las columnas donde queremos sumar los valores.
      Al aplicar como fórmula matricial (F2 y el proceso) Indicamos todas las filas de las columnas, que coincidan con el año de referencia.

      Saludos.

  • Como hago para que repita la operación? Quiero tener un codigo en la primera columna y que me vaya sumando todos los gastos con ese codigo.

    Osea quiero que sume todos los números de una misma columna que tengan cierto codigo en otra columna.

  • Hola buenos dias, como hago para sumar cifras de indicadores repetidos, por ejemplo

    enero l 3 l 4 l
    enero l 1 l 2 l
    febrero l 3 l 7 l
    febrero l 2 l 6 l

    que se sumen los enero y los febrero para que nada mas quede un indicador con el total

    enero l 4 l 6 l
    febrero l 5 l 13 l

    • Hola Efrain,

      Según la estructura que propones es complejo, BUSCARV solo admite valores no repetidos. Existen métodos para obtener la segunda o tercera vez que se repita, pero la fórmula sería muy compleja.

      En el ejemplo la estructura de los datos son cruzados.

      Te recomiendo utilices tablas dinámicas.

      Saludos.

  • Buen día
    En el documento [Libro1.xlsx]Hoja1 encuentro que para el valor A tengo un número 70, Hoja2, para el valor A tengo un número 80 y para Hoja3 no existe valor A, en algunos casos.
    ¿Cómo hago para que en una celda de otro libro (Libro2 por ejemplo) busque el valor A en todas las hojas del Libro1 y haga una suma? Y que el resultado aparezca, independientemente de que no encuentre valor A en algunas hojas de ese documento.
    Mi fórmula de BUSCARV es la siguiente:

    =BUSCARV(celda de referencia;’dirección del archivo\[nombre del archivo]\hoja1’rango de busqueda;columna de busqueda;FALSO)

    Esto solo me funciona para una hoja. Si sumo otra formula con hoja2 que encuentre el valor de referencia, realiza la suma. Si sumo otra formula con hoja3 que no encuentre el valor de referencia, sale error.

    Ojala me puedan ayudar, saludos!

  • buenos dias quisiera extraer el numero comprobante de pago de una hoja excel donde tiene las mismas caracteristicas.. cual e la formula ????

    n° cheque cod.cheque n° comprobante de pago
    72560234 065 2065

    • Hola Carmela,

      Para buscar un valor puedes aplicar la función BUSCARV. Revisa los argumentos de la función y aplica tus valores. No te puedo indicar la función escrita ya que necesitamos conocer el rango de los datos, la celda donde buscar el valor y la columna del comprobante.

      Si tienes problemas indica con mas detalles como tienes los datos.

      Saludos.

  • Hola buenas tardes. Queria saber si hay alguna forma de utilizar esto pero que sume las filas en lugar de las columnas? Te escribo un ejemplo para ver si me pueden ayudar.
    1 2 3
    A Mes Articulo Unidades vendidas
    B Enero Pan 30
    C Febrero Pan 30
    D Marzo Pan 50
    E
    F PAN (celda)
    Yo necesito en la celda “(celda)” la cantidad de unidades vendidas de pan en los 3 meses mencionados. Si tiro un buscarv normal +BUSCARV(F1; tabla de arriba;3;0), me tira el primer resultado que sale en la tabla, es decir, 30 unidades.
    Hay alguna forma para que en la (celda) me tire directamente las 110 unidades de los 3 meses en cuestión? Probé utilizar la formula que explican acá, la cual es excelente, pero en este caso no me sirve.

    Muchas gracias!

  • Hola buen dia,
    Tengo una planilla en una hoja con diferentes nombres en una columna y gastos producidos por ese nombre que se repite varias veces.
    En otro hoja quiero que me busque ese nombre y me sume todos los gastos que figura.
    Que formula puedo aplicar???
    Gracias

  • Tengo una base de datos de clientes y deseo saber cuantas cotizaciones solicito en el intervalos de 2 fechas, como podría hacerlo

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *