Buscar datos con BuscarV y sumar valores en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

En un rango de datos, necesitamos buscar un valor y sumar todos los datos de una condición mediante funciones, similar al empleo de las tablas dinámicas.

Buscar datos con BuscarV y sumar valores en Excel

Emplearemos las siguientes funciones anidándolas:

  • Función SUMA. Suma todos los números en un rango, en nuestro caso indicamos la columna.

  • Función BUSCARV. Busca en la primera columna de una matriz y se mueve en la fila para devolver el valor de una celda.

    La fúnción anidada se deberá insertar como fórmula matricial.

buscasuma04

 

Disponemos de un rango con datos cruzados, las filas muestran el año y las columnas diferentes países y deseamos buscar por el año deseado y algunos de los países.

 ABCDEFG
1EspañaMéxicoFranciaColombiaAlemaniaPerú
22016123456
3201524681012
42014369121518
  • IMPORTE EUROPA – 2016

  1. Ir a: Celda B7 / Escribir: 2016. Como el año que deseamos buscar para los valores de Europa.

  2. Ir a: Celda C7 / Escribir:

    =SUMA(BUSCARV(B7;A1:G4;{2;4;6};0))
  3. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=SUMA(BUSCARV(B7;A1:G4;{2;4;6};0))}.

  4. Mostrará 9 como la suma en el año 2016 para España, 1; Francia, 3 y Alemania 5.

buscasuma01
  • IMPORTE AMÉRICA – 2014

  1. Ir a: Celda B8 / Escribir: 2014. Como el año que deseamos buscar para los valores de América.

  2. Ir a: Celda C8 / Escribir:

    =SUMA(BUSCARV(B8;A1:G4;{3;5;7};0))
  3. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=SUMA(BUSCARV(B8;A1:G4;{3;5;7};0))}.

  4. Mostrará 36 como la suma en el año 2016 para México, 6; Colombia, 12 y Perú 18.

buscasuma02
  • IMPORTE TOTAL – 2015

  1. Ir a: Celda B9 / Escribir: 2015. Como el año que deseamos buscar para todos los valores.

  2. Ir a: Celda C9 / Escribir:

    =SUMA(BUSCARV(B9;A1:G4;{2;3;4;5;6;7};0))
  3. Pulsar la tecla F2, para editar la fórmula / Pulsar la tecla Control y mantenerla pulsada / Pulsar la tecla Mayús. y mantener las 2 teclas pulsadas / Pulsar la tecla Enter. Insertará la fórmula entre llaves como matricial {=SUMA(BUSCARV(B9;A1:G4;{2;3;4;5;6;7};0))}.

  4. Mostrará 42 como la suma en el año 2015 para España, 2; México, 4, Francia, 6, Colombia, 8, Alemania 10 y Perú 12.

buscasuma03
Nivel de dificultad: Avanzado Excel Avanzado

2 comentarios en “Buscar datos con BuscarV y sumar valores en Excel

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *