Año bisiesto en Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

Cuando trabajamos con fechas es importante identificar el año bisiesto en Excel.

El sistema de fechas empleado por Excel se basa en el calendario gregoriano, que se establece por primera vez en 1582 por el Papa Gregorio XIII.

En el calendario gregoriano, un año normal consta de 365 días. Dado que la longitud real de un año de sideral (es decir, el tiempo necesario para que la Tierra gira una vez alrededor del sol) es en realidad de 365.25635 días, "año bisiesto" de 366 días se utiliza una vez cada cuatro años para eliminar el error causado por tres años normales (pero breves).

Año bisiesto en Excel

El calendario gregoriano estipula que un año que es divisible por 100 (por ejemplo, 1900) es un año bisiesto sólo si también es divisible por 400:

– Los años "1700, 1800, 1900, 2100, 2200, 2300, 2500, 2600" no son años bisiestos (al ser divisibles por 100, pero no por 400).

– Los años "1600, 2000 y 24000" son años bisiestos al ser divisibles por 100 y 400.

Emplearemos las siguientes funciones:

  • Función SI. Comprueba si se cumple una condición.

  • Función RESTO. Devuelve el resto de la división.

  • Función Y. Devuelve VERDADERO si todos sus argumentos son verdaderos.

  • Función O. Devuelve VERDADERO si algún argumento es VERDADERO.

Función anidada=SI(O(RESTO(A2;400)=0;Y(RESTO(A2;4)=0;RESTO(A2;100)<>0)); "Año bisiesto";"No es año bisiesto")
  1. En la columna A disponemos de los años que deseamos evaluar.

  2. Ir a: Celda B2 / Escribir:

    =SI(O(RESTO(A1;400)=0;Y(RESTO(A1;4)=0;RESTO(A1;100)<>0)); "Año bisiesto"; "No es año bisiesto")

    O también desde el asistente de funciones, Ir a: Cinta opciones / Fórmulas / Biblioteca de funciones / Lógicas / SI.

  3. Seleccionar la celda B2 / Copiar. Celda que incluye la fórmula.

  4. Seleccionar el rango B3:B12 / Pegar como fórmula. Rango donde pegar la fórmula.

Año bisiesto en Excel: Hoja con columna B indicando si es año bisiesto el valor en A.

Mediante las funciones SI, Y, O y RESTO podemos mostrar el año bisiesto en Excel.

Nivel de dificultad: Avanzado Excel Avanzado

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *