14 métodos para contar números en celdas Excel

Compatibilidad: Truco compatible con Excel 365Truco compatible con Excel 2019Truco compatible con Excel 2016Truco compatible con Excel 2013Truco compatible con Excel 2010Truco compatible con Excel 2007

En muchas ocasiones necesitamos contar valores de celdas, te mostramos, 14 métodos para contar números en celdas Excel.

14 métodos para contar números en celdas Excel

En la columna A disponemos de diferentes valores y deseamos conocer como contar números por diferentes características.

  • NÚMERO DE CELDAS CON NÚMEROS

  1. Ir a: Celda D1 / Escribir:

    =CONTAR(A2:A10)
  2. Verificar como muestra 6. Como las celdas con números.

Celda D1 contando las celdas con número
 
  • NÚMERO DE CELDAS CON VALORES

  1. Ir a: Celda D2 / Escribir:

    =CONTARA(A2:A10)
  2. Verificar como muestra 8. Como las celdas no vacías.

Celda D2 contando las celdas con valores
 
  • NÚMERO DE CELDAS SIN NÚMEROS

  1. Ir a: Celda D3 / Escribir:

    =SUMAPRODUCTO(--NO(ESNUMERO(A2:A10))))
  2. Verificar como muestra 3. Como las celdas sin números.

Celda D3 contando las celdas sin números
 
  • NÚMERO DE CELDAS VACÍAS

  1. Ir a: Celda D4 / Escribir:

    =CONTAR.BLANCO(A2:A10)
  2. Verificar como muestra 1. Como las celdas vacías.

Celda D4 contando las celdas vacías
 
  • NÚMERO DE CELDAS CON 5 CARACTERES

  1. Ir a: Celda D5 / Escribir:

    =CONTAR.SI(A1:A10;"??????"))
  2. Verificar como muestra 1. Como las celdas que contienen 5 caracteres.

Celda D5 contando las celdas con 5 números
 
  • NÚMERO DE CELDAS CON MÁS DE 10 CARACTERES

  1. Ir a: Celda D6 / Escribir:

    =SUMAPRODUCTO(N(LARGO(A2:A10)>10))
  2. Verificar como muestra 1. Como las celdas que contienen más de 10 caracteres.

Celda D6 contando las celdas con más de 10 caracteres
 
  • NÚMERO DE CELDAS CON NÚMEROS POSITIVOS

  1. Ir a: Celda D7 / Escribir:

    =CONTAR.SI(A2:A10;">0")
  2. Verificar como muestra 4. Como las celdas que contienen números positivos.

Celda D7 contando las celdas con números positivos
 
  • NÚMERO DE CELDAS CON NÚMEROS NEGATIVOS

  1. Ir a: Celda D8 / Escribir:

    =CONTAR.SI(A1:A10;"<0")
  2. Verificar como muestra 1. Como las celdas que contienen números negativos.

Celda D8 contando las celdas con números negativos
 
  • NÚMERO DE CELDAS CON VALOR CERO

  1. Ir a: Celda D9 / Escribir:

    =CONTAR.SI(A2:A10;"=0")
  2. Verificar como muestra 1. Como las celdas que contienen valor 0.

Celda D9 contando las celdas con valor cero
 
  • NÚMERO POR 2 CRITERIOS (=0; =25)

  1. Ir a: Celda D10 / Escribir:

    =SUMA(CONTAR.SI(A2:A10;"=0");CONTAR.SI(A2:A10;"=25"))
  2. Verificar como muestra 3. Como las celdas que contienen valor 0 y 25.

Celda D10 contando las celdas con 2 criterios
 
  • NÚMERO POR VALORES ÚNICOS

  1. Ir a: Celda D11 / Escribir:

    =SUMA(--(FRECUENCIA(A1:A10;A1:A10)>0))
  2. Verificar como muestra 5. Como las celdas que contienen únicos sin repetidos.

Celda D11 contando las celdas con números únicos
 
  • NÚMERO COMPRENDIDOS ENTRE 10 Y 30

  1. Ir a: Celda D12 / Escribir:

    =CONTAR.SI.CONJUNTO(A2:A10;">=10";A2:A10;"<=30")
  2. Verificar como muestra 3. Como las celdas que contienen números dentro del rango 10 y 30.

Celda D12 contando las celdas con números entre 10 y 30
 
  • NÚMEROS CUYO SEGUNDO NÚMERO ES 5

  1. Ir a: Celda D13 / Escribir:

    =SUMAPRODUCTO(--(EXTRAE(A2:A10;2;1)="5"))
  2. Verificar como muestra 2. Como las celdas que contienen números con 5 en la posición 2.

Celda D13 contando las celdas con segundo dígito 5
 
  • NÚMEROS EXCLUYENDO EL 1000

  1. Ir a: Celda D14 / Escribir:

    =CONTAR.SI(A2:A10;"<>"&1000)
  2. Verificar como muestra 8. Como las celdas que contienen números excepto el número 1000.

Celda D14 contando las celdas con números excepto el 1000
Nivel de dificultad: Avanzado Excel Avanzado

2 comentarios en “14 métodos para contar números en celdas Excel

  • Interesante propuesta, las voy a practicar si me puedieras colaborar con la formula para encontrar en una base de numeros del 000 a 999 los numeros "combinados". muchas gracias y exitos

    • Hola Fernando,

      Necesitaría más información de lo que deseas realizar.

      Iniciemos a partir del 100 que es el primer número de 3 dígito, luego 999 - 100 = 899, a este número 899 +1(que es el 100), obtenemos 9oo, por tanto entre el 100 al 999 existen 900 números de 3 dígitos.

      Saludos.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.